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Using your SuCasa templa  tes 
On SuCasa, you can purchase a variety of CSS templates, menus, and even 
complete sites. Any SuCasa design can be customized to suit your needs in 
any appropriate editor. As an added bonus, many SuCasa designs are 
compatible with WebAssist products. This provides you with additional tools 
to help with editing your design, or creating your site. 

This document shows you how you to work with your SuCasa purchase to get 
the most out of the design or site. 

What Do You Need to Start?  

• SuCasa .zip file 

• Any HTML or WYSIWYG editor 

• Photoshop or Fireworks for customizing graphics 

Downloading your purchase 

Once you  a design from SuCasa, you will have the  have purchased
opportunity to download the .zip file that contains the design and 
accompanying pages at any time. 
This step can be skipped if you have already downloaded the .zip file. 

1. Navigate to https://sucasa.webassist.com/. 

2. Choose the Mi Casa tab. 

3. Enter your username and password, click Login. 

4. Choose the Downloads button. 

The Downloads section displays all your purchase, and allows you to 
download each design at any time. 

5. Click the Download button next to your purchase. 

6. In the Window that display igate to the location you wish to s, nav
download the file. 

7. Click Save. 

The file will begin downloading to the location you specified. 

Once the progress bar displays Complete! you know your download has 
fin hed. is



 
Note: Please refrain from navigating to a different page, or closing your 
browser until the progress bar has completed. This may cause your 
download to quit. 

8. Click Close on the Progress Bar. 

9. Navigate to the location which you downloaded the design. 

Extracting the .zip contents 

Windows Users 

1. Right-click on the .zip file. 

2. Choose Extract All. 

3. When the Extract Compressed Folders window displays, choose 
Extract. 

Mac Users 

4. Double-click the .zip file. 

5. The unzipped version of the file will be available in its original location. 

Once you have unzipped your file, you are ready to work with your design.  
Navigate to the section below that relates to the type of design you are 
working with. 

• Working with CSS designs 

• Working with CSS menus  

• Working with Full Sites 
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ns Working with CSS desig
The following details how to work with the CSS designs purchased from 
SuCasa to make changes, and incorporate the CSS into your site. 

What is included?  

All CSS designs available from SuCasa include HTML output which includes 
the necessary graphics and CSS style sheets. Various additional items may 
also be included such as Dreamweaver templates (.dwt), PNG/PSD source 
files, and WebAssist product compatible .zip files. 

In some cases, the HTML is stored in a separate directory, or .zip file. Before 
you proceed make sure to extract the contents of the .zip. 

If your design is compatible with CSS Sculptor, see 
the Using CSS Designs with CSS Sculptor at the end 
of this section. 

Changing graphics 

Modifying the graphics of the design will probably be the first priority in 
making the design suit your needs. Although there are many possible ways 
to modify the graphics that are included in your design, the following details 
one method. 

If PNG/PSD source files have been included with your purchase, and you own 
one of these two image editing applications, use these files for creating your 
new images. 

1. Create all replacement graphics using an image editing application 
such as Fireworks or Photoshop. 
To avoid problems with the CSS, you should ensure that the 
dimensions of the images are exactly the same as the image it is 
replacing. 

2. Save all new images to the images directory of your design. 

3. Open the included CSS style sheet in your HTML or text editor. 

4. Locate the reference to the images to be replaced and change the file 
names to the correct replacements. 

Note: You may want to delete the original images as they would no 
lon er be necessary. g
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5. Save the file. 

To view your changes, open the HTML file in your browser. 

Creating your site 

On esign to suit your needs, you are ready ce you have customized the CSS d
to sta t creating your pages. If you are an Ar dobe Dreamweaver user, you 
can easily convert the design to a .dwt template. Review the Own 
Dreamweaver? section for instructions. 

If you do not own Dreamweaver or any other WYSIWYG application, you can 
easily create a web site from your design by using a free text editor such as 
Notepad.  Simply open the HTML file in Notepad and enter your pages 
content in the appropriate <div> tag in place of the placeholder content that 
already exists.  

Own Dreamweaver? 

If you own Dreamweaver, the e rate your purchased asiest way to incorpo
design into your site, is through using a Dreamweaver template (.dwt).  

If your design did not include a .dwt file follow these steps to creating one. 

1. Copy the HTML, images and CSS files from your SuCasa design to your 
defined site in Dreamweaver 

2. Open the HTML file that contains your purchased design. 

3. From the File menu, choose Save As Template. 

4. Enter a name for your template and click Save. 

5. When asked to Update Links, choose OK. 

Your new template is now stored in the Templates folder of your 
Dreamweaver defined site. 

To apply the design to the other pages in your site: 

1. Select the Assets tab. 

2. Right-click on your new .dwt file, and choose Apply. 
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To create new pages from a template: 

1. From the Assets panel, right-click the .dwt file. 

2. Choose New from Template. 

Using CSS Designs with CSS Sculptor 

Eric Meyer’s CSS Sculptor provides you with an easy-to-use interface for 
creating standards-compliant CSS web sites within Dreamweaver. Many CSS 
designs purchased from SuCasa include a CSS Sculptor compatible .zip file 
that can be used to make further modifications to your design. 

If your CSS design is CSS Sculptor compatible, the .zip file you downloaded 
from SuCasa should also be able to import into the CSS Sculptor Layout 
Manager. Or, there should be an additional CSS Sculptor .zip file provided.  

Foll  ow these instructions for importing the file into CSS Sculptor and making 
changes. 

1. With Dreamweaver open and CSS Sculptor installed, choose Insert > 
WebAssist > CSS Sculptor > Layout Manager. 

2. Choose Import. 

3. Select your CSS design .zip or the CSS Sculptor .zip provided within 
your design’s folder. 

4. Click Open. 

Once you have imported your design, you can open the design in CSS 
Sculptor to make further modifications. 

5. Select the design from the list in the Layout Manager. 

6. Choose Edit to open CSS Sculptor. 

A variety of resources for using CSS Sculptor can be found on 
WebAssist.com. Please refer to that documentation for help with 
customizing your design. 
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Working with CSS menus 
The following details how to work with the CSS menus purchased from 
SuCasa, to make changes and incorporate the menu into your site. 

What is included? 

All CSS menus available from SuCasa include HTML output which includes the 
necessary graphics and CSS style sheets. Various additional items may also 
be included such as PNG/PSD source files, and WebAssist product compatible 
.zip files. 

In some cases, the HTML is stored in a separate directory, or .zip file. Before 
you proceed make sure to extract the contents of the .zip. The HTML file 
provides the code that you would want to copy to your existing page to add 
the navigation to your site. 

If your design is compatible with CSS Menu Writer, see 
the Using CSS Designs with CSS Menu Writer at the 
end of this section. 

Changing colors or graphics 

Depending on the type of menu you have purchased, it may utilize images 
for your menu to appear a certain way. Other menus will use colors in the 
CSS. If you wish to customize the Menu Writer design to suit your needs, or 
match the colors used on your site, you may change the colors, or images 
that are used. 

1. Locate the images directory of your menu, and open all images in your 
image editing application such as Fireworks or Photoshop. 

2. Make any modifications necessary to the images. 
To avoid problems with the CSS, do not change the size of any 
images. 

3. Save all new images to the images directory of your design. 
If using the same file names, you will not need to modify the CSS. 

4. Open the included CSS style sheet in your HTML or text editor. 

5. Locate the reference to the images to be replaced and change the file 
names to the correct replacements. 

6. Save the file. 
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To view your changes, open the HTML file in your browser. 

For menus that do not use images, you will need to modify the color 
values within the CSS style sheet that is provided with your menu. 

Copying the menu into your site 

Once you have customized the CSS menu to suit your needs, you are ready 
to add the menu to your page.  

1. Open the HTML page in any WYSIWYG or text editor, such as 
Dreamweaver or Notepad. 

2. In the <head> copy the references related to menu. 
In most cases this should include a reference to a javascript file, and 
the style sheet reference. 

3. Paste this code in the <head> region of your page. 

4. Return to your menu HTML page. 

5. Within the <body> tags copy the unordered lists and any other code 
related to your menu. 

6. Paste this code in the appropriate location within the <body> tags of 
your page. 
Typically, this location would be between the Navigation <div> tag. 

7. Save your page, and open the file in your browser to view your 
changes. 

 

Using CSS Menus with CSS Menu Writer 

CSS Menu Writer provides you with an easy-to-use interface for creating 
standards-compliant CSS-based menus within Dreamweaver. Many CSS 
menus purchased from SuCasa include a CSS Menu Writer compatible .zip 
file that can be used to make further modifications to your design. 

If your CSS menu is CSS Menu Writer compatible, the .zip file you 
downloaded from SuCasa should also be able to import into the CSS Menu 
Wr  iter Layout Manager. Or, there should be an additional CSS Menu Writer
.zip file provided.  

Foll Menu Writer and ow these instructions for importing the file into CSS 
making changes. 
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1. With Dreamweaver open and CSS Menu Writer installed, choose 
Insert > WebAssist > CSS Menu Writer > Layout Manager. 

2. Choose Import. 

3. Select your CSS menu .zip or the CSS Menu Writer .zip provided within 
your design’s folder. 

4. Click Open. 

Once you have imported your design, you can open the design in CSS 
Menu Writer to make further modifications. 

5. Select the design from the list in the Layout Manager. 

6. Choose Edit to open CSS Menu Writer. 

Adding your CSS Menu Writer menu to your page 

1. With your page open in Dreamweaver, place your cursor in the 
Navigation div where you wish to have your menu inserted. 

2. From the Insert menu, choose WebAssist > CSS Menu Writer > 
New Menu. 

3. From the Style menu, choose your menu. 

4. Modify the menu items and design. 

5. Click Finish to insert the menu to your page. 

6. Save your page and preview in your browser to view your changes. 

A variety of resources for using CSS Menu Writer can be found on 
WebAssist.com. Please refer to that documentation for help with 
customizing your menu. 
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Working with Full sites 
The fo , llowing details how to work with the full sites purchased from SuCasa
to customize and turn them into your own. 

What is included? 

All full sites contain, at a minimum, a Home page, Content page, and 
navigation. Most full sites on SuCasa utilize a specific theme and include 
multiple pages that evolve around this theme. This can include a variety of 
different layouts to accommodate for specific page types. 

The following lists the files that are included in all full sites. 

• HTML files for the Home page, Content Page(s) including navigation 

• All necessary CSS style sheets 

• Images directory containing all images 

• PSD/PNG source files (Optional) 

• Dreamweaver (.dwt) templates (Optional) 

• WebAssist product compatible .zip files. (Optional) 
SiteAssist Professional Layout, SiteAssist Professional Site Type, 
SiteAssist Professional Page Type, CSS Sculptor, CSS Menu Writer 

In some cases, the HTML files are stored in a separate directory, or .zip file. 
Before you proceed make sure to extract the contents of the .zip.  

If your design is compatible with SiteAssist 
Professional, see the Using Full Sites with SiteAssist 
Professional at the end of this section. 
 
Note: Many full sites also include CSS Menu Writer and CSS Sculptor 
compatible .zip files. See the appropriate sections above for help using those 
files.  

Modifying your design 

Many full sites include a Dreamweaver template (.dwt) to make it easier to 
update the design of all your pages within Dreamweaver. If you are not a 
Dreamweaver user, you will have to modify the appearance of each page 
individually. However, for images such as the logo, this can be easily 
modified by following these steps. 
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Modifying the graphics of the design will probably be the first priority in 
making the design suit your needs. Although there are many possible ways 
to modify the graphics that are included in your design, the following details 
one method. 

1. Create all replacement graphics using an image editing application 
such as Fireworks or Photoshop. 
To avoid problems with the CSS, you should ensure that the 
dimensions of the images are exactly the same as the image it is 
replacing. 

2. Save all new images to the images directory of your design. 

3. Open the included CSS style sheet in your HTML or text editor. 

4. Locate the reference to the images to be replaced and change the file 
names to the correct replacements. 

Note: You may want to delete the original images as they would no 
longer be necessary. 

5. Save the file. 

To view your changes, open your site pages in your browser. 

15BUsing Full Sites with SiteAssist Professional 

Full sites can include up to three .zip file for importing into SiteAssist 
Professional. At a minimum, any SiteAssist Professional compatible site will 
contain a layout .zip file.  The following details the types of .zip files and 
what each contains. 

• Layout: Contains the design of the Home and Content pages, and the 
included navigation. 

• Site type: Contains the site theme, including each type of content 
page that is to be included in the site. 

• Page type: Contains any custom page types that are included with 
your site. 

All of the included .zip files should be installed into SiteAssist Professional 
before you begin the SiteAssist Professional wizard to create your site. 

The following details how to install each of your SiteAssist Professional 
.zip files. 
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21BInstalling the Layout .zip file 

1. Extract the contents of the .zip file that you downloaded from SuCasa. 

2. With SiteAssist Professional installed, and Dreamweaver open, choose 
Insert > WebAssist > SiteAssist Professional > Layout 
Manager. 

3. Select Import. 

4. Navigate to the extracted contents of your .zip file. 

5. Select the SiteAssist Professional layout .zip file. 
This file should be clearly named to help you identify it. 

6. Click Open. 

Once the import process is complete, the layout will be listed in the 
Layout Manager. 

22BInstalling the Site Type .zip file 

1. From the product menu list, choose SiteAssist Professional Site 
Types. 

2. Select Import. 

3. Select the SiteAssist Professional site type .zip file. 
This file should be clearly named to help you identify it. 

4. Click Open. 

23BInstalling the Page Types .zip file 

1. From the product menu list, choose SiteAssist Professional Page 
Types. 

2. Select Import. 

3. Select the SiteAssist Professional site type .zip file. 
This file should be clearly named to help you identify it. 

4. Click Open. 
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16BCreating your site with SiteAssist Professional  

Once you have imported the provided .zip files, you can use SiteAssist 
Professional to create your site. The following shows you how to use get 
started with the SiteAssist Professional wizard to create your site. 

1. In Dreamweaver, choose Insert > WebAssist > SiteAssist 
Professional > Build Site. 

2. Choose the desired Site Type. 
If you installed a site type .zip file, you would choose that from the 
menu list. 

3. Click Next. 

4. Choose the Layout for your design from the list. 

Note: For most full sites available on SuCasa, the Design menu will have 
no effect on the design of your site. 

5. Click Next. 

6. Continue through the wizard to customize your site however you like. 

Note: If a page type .zip file was imported, the appropriate page types 
will be used as you progress through the wizard. 

For more assistance using SiteAssist Professional, please review the help 
documentation and Solution Recipes available from HUWebAssist.comU 
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