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User Interface Access

WebAssist Category of Insert toolbar

SiteAssist Professional Wizard

SiteAssist Professional Layout Manager

Create new Page type

Build SiteAssist Professional Site*

●     Site > New SiteAssist Professional Site

●     Modify > New SiteAssist Professional Site

●     Insert > WebAssist > SiteAssist Professional > Build Site... 
 
*Option not available when the current site in Dreamweaver already contains a SiteAssist Professional site. 

Modify SiteAssist Professional Site*

●     Site > Modify SiteAssist Professional Site

●     Modify > Modify SiteAssist Professional Site 
 
*Option only available when the current site in Dreamweaver is a SiteAssist Professional site.

SiteAssist Professional Layout Manager

●     Insert > WebAssist > SiteAssist Professional > Layout Manager

Create page type*

●     Insert > WebAssist > SiteAssist Professional > Create Page Type 
 
*Requires that a content page created by SiteAssist Professional be open in Dreamweaver.

   



 

Creating a SiteAssist Professional Site

Creating your SiteAssist site is a 5-step process. 

1.  Configuring general site settings

2.  Selecting layout options

3.  Configuring pages and navigation

4.  Configuring your site footer

5.  Preset and Output options

 
After completing the wizard, SiteAssist Professional will create all the pages and navigation you specified to be 
created. If you want to make any changes, you can always re-enter the SiteAssist Wizard. 
 
 
 
 

   



 

Step 1: Configure general site settings

SiteAssist Professional allows you to specify a site type which determines the types of pages that are created for your site. You will 
have the option later in the wizard to review the pages that will be created and customize them to suit your needs. 
 
Note: The last step of the wizard allows you to specify a custom name for the site type that you have used. This allows you to create 
multiple sites using your own custom site types. 
 
Site type: Choose the site type that best matches the kind of site you wish to create.  
 
Description: The Description text lists the pages created for each selected site type. 
 

 



 

Step 2: Select layout options

Home Page & Content Page

Step 2 allows you to select Layout and Design configurations for both the home and content pages of your site. 
 
Layout: Select the layout you want to use in your site. 
 
Design: Select the design you want to use in your site. 
 
Define: Opens the SiteAssist Professional Layout Manager which allows you to import a new Layout, among other features. 
 
The Preview pane displays how a selected configuration will appear in the pages created for your site based on your selections. Click 
once on a preview image to view the configuration in your default browser. 
 

 



 

Step 3: Configure pages and navigation

Step 3 displays all the pages that will be created when you complete the SiteAssist Professional wizard. Here you can customize the 
page type for each of the content pages, add or remove pages, and modify your site navigation. 
 

: Adds a new document within the hierarchy. By default, the page type is Blank Page.

   

: Deletes a selected page from the hierarchy.

   

: Adds a duplicate of the selected page within the hierarchy. If a branch (a page with subpages) is selected, choose either 
Duplicate page or Duplicate branch.

 

 

 
Duplicate page: Duplicates only the selected page and appends "copy" to the page name. All subpages are ignored. 
 
Duplicate branch: Duplicates the entire branch, and appends "copy" to each page name. 
 

   
: Only available for page types that are external links. With a page of this type selected, this button opens a dialog that 

allows you to specify an external link: 
 

 

 
This allows you to track an external link within the hierarchy and navigation of the site as an included page. 
 
Note: An external link is one that is not managed by SiteAssist Professional; such a link can be within the defined 
Dreamweaver site or entered as an absolute URL. In this situation, SiteAssist Professional does not create a page.

   
: Moves a selected page in the display up within the current hierarchy.

   

: Moves a selected page in the display down within the current hierarchy.

   
: Moves a selected page in the display left within the current hierarchy.

   
: Moves a selected page in the display right within the current hierarchy.

 
To modify a page, select the page within the display pane. Once selected, you can modify the Page title and select a Page type. The 
Preview pane displays the layout for a selected Page type. 
 
Note: If re-entering the SiteAssist wizard to modify your SiteAssist Professional site, all content will be lost on pages where the page 



type has been changed.  
 
CSS Menu Writer navigation menus: The primary navigation menus are generated based on the second tier of entries displayed in 
Step 3. For example, in the step illustrated here, the initial navigation items would be Manage Orders and Manage Products. 
 
Note: Navigation menus available with each SiteAssist Professional preset layout can be customized using CSS Menu Writer, or by 
manually modifying the outputted CSS stored in the CSSMenuWriter folder. However, any changes made to the CSS Menu Writer CSS 
after creating your SiteAssist Professional site, will be overwritten if you choose to re-enter the SiteAssist Professional wizard. 
 

 



 

Step 4: Configure site footer

Configure the pages linked within your site footer that are not included in your top level navigation. These pages are not displayed in 
the previous step. 
 
Specify the page title, type, and relative position for each page listed using the available controls: 
 

: Adds a new document within the hierarchy. By default, the page type is Blank Page.

   

: Deletes a selected page from the hierarchy.

   
: Adds a duplicate of the selected page.

   
: Only available for page types that are external links. With a page of this type selected, this button opens a dialog that 

allows you to specify an external link: 
 

 

 
This allows you to track an external link within the hierarchy of the site as an included page.

   
: Moves a selected page in the display up within the current hierarchy.

   

: Moves a selected page in the display down within the current hierarchy.

 
Each page listed will be included in the footer of the site. Each link will be separated using a character specified in the Separator field 
at the bottom of the user interface. 
 
To modify a page, select the page within the display pane. Once selected, you can modify the Page title and select a Page type. The 
Preview pane displays the layout for a selected Page type. 
 
Note: If re-entering the SiteAssist wizard to modify your SiteAssist Professional site, all content will be lost on pages where the page 
type has been changed.  
 



 

   



 

Step 5: Preset and Output options

The final step of the SiteAssist Professional wizard allows you to select the necessary output or preset options. 

Placeholder & Comments

This section determines additional content that is added to the layout when the page is created. This includes placeholder content for 
the layout components of the page (header, footer, columns, headings, etc.). It also includes comments in the source code to assist in 
understanding how the CSS properties that are applied, control the layout and design of the page. 
 

 

 
Placeholder content: Select the level of content that should be shown in each layout component when the page is created. Available 
options are: 

●     Full: When selected, includes the name of the layout component in the heading (h1), several lines of lorem ipsum style body 
text, as well as additional heading levels (h2, h3).

●     Minimal: When selected, includes the name of the layout component in the heading (h1), and a single sentence of body text.

●     None: When selected, no content is added to the layout components on the page.

Include CSS comments: When checked, adds comments specific to the layout components specified in the source code of the new 
page (i.e. body, container, header, content, column, footer). This includes general information on how the CSS properties determine 
how these components render. 

 

Site Types

Site types relate to the page structure and page types used in a site. You can save the page structure and page types that you 
customized in steps 3 and 4, as a new site type that can be used in future sites.  
 

 

 
The following options are available when determining if/how to save your current site type: 
 
Don't save a site type: A new site type will not be created when finishing the SiteAssist Pro wizard. 
 
Overwrite existing site type: This option overwrites the existing site type that was selected on step 1 of the SiteAssist Pro wizard. 
 
Important: The site types installed with SiteAssist Professional are not protected and can be overwritten. Best practice is to provide a 
new name for a customized site type to avoid removing the original. Additionally, all original site types are uninstalled if the SiteAssist 
Professional extension is uninstalled for any reason. However, any new site types will be preserved when re-installing or updating the 
extension.  
 
Optional: You can export your custom site types through the Layout Manager, allowing you to copy them to a different machine or 
share with them with other SiteAssist Professional users. 
 
Create new site type: Creates a new site type that is accessible in step 1 of the SiteAssist Professional wizard, and the Layout 



Manager. In the Name field, specify the name for the new site type. 

 

Page Generation

This section determines the doctype tag applied to the top of the page, as well as if a new page is created upon completing 
configuration when a preset is being saved or overwritten. 
 

 

 
Doctype: Select the doctype tag that should be written to the top of the page. In most cases, XHTML 1.0 Strict is appropriate to use 
as your document type. More information regarding doctypes can be found in their specification at the W3C website, as linked next to 
each of the below options: 

●     XHTML 1.1 (http://www.w3.org/TR/xhtml11/)

●     XHTML 1.0 Strict (http://www.w3.org/TR/xhtml1/)

●     XHTML 1.0 Transitional (http://www.w3.org/TR/xhtml1/)

●     HTML 4.0.1 Strict (http://www.w3.org/TR/html4/)

●     HTML 4.0.1 Transitional (http://www.w3.org/TR/html4/)

   



 

Re-entering the SiteAssist Professional Wizard

After running through the SiteAssist Professional wizard and creating your pages, you can easily re-enter the wizard 
to make any necessary modifications. 

●     With your SiteAssist Professional site selected in the Dreamweaver Files panel, select Site > Modify 
SiteAssist Professional Site. 
 

●     Proceed through the SiteAssist Professional wizard to make any necessary changes. Since all options from 
the original run-through of the wizard are selected, the Finish button is available at any point during re-entry. 
 

Note: The SiteAssist Professional wizard automatically opens at step 2, since options for step 1 cannot be changed 
on re-entry. 
 
Important: If you have added new content to your SiteAssist Professional pages, you must be careful not to 
overwrite the content on re-entry. To avoid this, DO NOT change the page type in steps 3 or 4 of the SiteAssist 
Professional wizard on any pages which contain new content. For pages with new content where you need to change 
page type, it is recommended that you rename the current page with a new name before re-entering the SiteAssist 
Professional wizard. Content can then be copied over to the new page that will be created. 
 
mystyles.css: SiteAssist Professional creates a my_styles.css style sheet that allows you to insert your own CSS 
styles to be applied to your pages. You can ensure that your new CSS is not overwritten when re-entering SiteAssist 
Professional, by storing them in this file. 
 
 

   



 

Layout Manager

The Layout Manager provides users with the ability to manage their existing and custom layouts, as well as create new 
layouts. 

Access

The following locations in Dreamweaver open the Layout Manager. 

●     From the WebAssist category of the Insert toolbar: 

Insert > WebAssist > SiteAssist Professional > Layout Manager 
 
 
From the Product menu list, choose from the following 3 SiteAssist Professional options:  
 

●     SiteAssist Professional Layouts

●     SiteAssist Professional Page Types

●     SiteAssist Professional Site Types 
 

 

 

Layouts

The SiteAssist Professional Layouts section allows you to manage the layouts you have installed in SiteAssist. By default, 
the only layouts that appear are those pre-installed with the SiteAssist professional extension. 
 
New: Loads the SiteAssist Professional Add New Layout wizard allowing you to create custom layouts using Dreamweaver 
templates, CSS Sculptor templates, and CSS Menu Writer navigation menus. 
 
Remove: Will remove the selected layout. 
 
Export: Will export the selected layout to a .zip format for backup or importing onto a different machine using SiteAssist 
Professional. 
 
Import: Allows you to select a SiteAssist Professional layout in .zip format for importing. 
 



 

Page Types 

The SiteAssist Professional Page Types section allows you to manage the page types you have created in SiteAssist. By 
default, SiteAssist Professional does not contain pre-installed page types and this menu will display empty.  
 
Note: Using the Create Page Type wizard, you can easily create new page types from any already created SiteAssist 
Professional page. 
 
Remove: Will remove the selected page type. 
 
Export: Will export the selected page type to a .zip format for backup or importing onto a different machine using 
SiteAssist Professional. 
 
Import: Allows you to select a SiteAssist Professional page type in .zip format for importing. 
 



 

 

Site Types 

The SiteAssist Professional Site Types section allows you to manage the site types in SiteAssist. By default, the only site 
types that appear are those pre-installed with the SiteAssist professional extension. However, you can choose to save 
custom site types on the last step of the SiteAssist Professional wizard. 
 
Remove: Will remove the selected site type. 
 
Export: Will export the selected site type to a .zip format for backup or importing onto a different machine using SiteAssist 
Professional. 
 
Import: Allows you to select a SiteAssist Professional site type in .zip format for importing. 
 



   



 

Creating New Layouts

Using the SiteAssist Professional Create New Layouts wizard, you can create a custom layout using the design and 
navigation of your choosing. 
 
Each SiteAssist Professional layout is composed of a template or design created by Dreamweaver or Eric Meyer's CSS 
Sculptor, and a navigation menu created with CSS Menu Writer. Each layout has a different set of options for the 
home page and the content pages.  
 
To access the Create New Layouts wizard, choose New from the SiteAssist Professional Layout Manager. 
 
The wizard consists of 4 steps:

●     Specifying Home Page layout

●     Identifying Home Page regions

●     Specifying Content Page layout

●     Identify Content Page regions 
 

   



 

Specifying Home Page Design

The first step in creating a new layout is to specify the settings for the Home Page.  

●     Layout name: Enter a name for your new layout. This name will display in the layout manager and when choosing a layout from 
the SiteAssist Professional wizard.

●     CSS Sculptor: Allows you to select from any of the layouts currently in Eric Meyer's CSS SCulptor 
 
Note: If CSS Sculptor is not installed, this option will be disabled.

●     Dreamweaver Template: Allows you to select from any Dreamweaver template (.dwt) currently stored in the Templates folder of 
the current site. 
 
Note: A page must be opened from the defined site prior to opening the SiteAssist Professional Layout Manager, in order to select 
a Dreamweaver template. 

   



 

Identify Home page regions

Step 2 of 4 requires you to specify the CSS Menu Writer menu, and content region settings for your Home Page design. 

Menu

●     CSS Menu Writer preset: Allows you to select from any CSS Menu Writer preset. 
 
Note: If CSS Menu Writer is not installed, you will only be able to select from the Menu Writer menus that are included in the SiteAssist 
Professional installation. CSS Menu Writer allows you to create customized CSS Menu navigation that you could use to create your SiteAssist 
Professional site.

●     Alignment: Specify left or right alignment for your navigation menu.

Regions

●     Menu: Specify the editable region or <div> element to insert your navigation menu.

●     Content: Specify the editable region or <div> element to insert content.

●     Footer: Specify the editable region or <div> element to insert your footer links. 
 

 

 

   



 

Specify Content Page Design

Step 3 of 4 requires you to specify the CSS Sculptor layout or Dreamweaver template to use for your Content pages design. 

●     CSS Sculptor: Allows you to select from any of the layouts currently in Eric Meyer's CSS SCulptor 
 
Note: If CSS Sculptor is not installed, this option will be disabled.

●     Dreamweaver Template: Allows you to select from any Dreamweaver template (.dwt) currently stored in the Templates folder of 
your currently selected defined site. 
 
Note: A page must be opened from the defined site prior to opening the SiteAssist Professional Layout Manager, in order to select 
a Dreamweaver template.

 

 

 



 

Identify Content Page Regions

Step 4 of 4 requires you to specify the CSS Menu Writer menu, and content region settings for your Content page's design. 

Menu

●     CSS Menu Writer preset: Allows you to select from any CSS Menu Writer preset. 
 
Note: If CSS Menu Writer is not installed, you will only be able to select from the Menu Writer menus that are included in the 
SiteAssist Professional installation. CSS Menu Writer allows you to create customized CSS Menu navigation that you could use to 
create your SiteAssist Professional site.

●     Alignment: Specify left or right alignment for your navigation menu.

Regions

●     Menu: Specify the editable region or <div> element to insert your navigation menu.

●     Content: Specify the editable region or <div> element to insert content.

●     Footer: Specify the editable region or <div> element to insert your footer links.

 

 



 

Create page type

SiteAssist Professional allows you to create your own custom page types that can be used when building your sites.  
 
In order to create a new page type follows these steps: 
 

●     Open a page in Dreamweaver that was created by SiteAssist Professional.

●     Customize the page to appear as you would like the page type.

●     Select Insert > WebAssist > SiteAssist Professional > Create Page Type.

●     Enter name in Page Type field.

●     Click OK.
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