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CSS Menu Writer Menu

The CSS Menu Writer Menu provides you with an array of options and settings that allow complete customization of your horizontal or 
vertical navigations. 
 
The following sections detail the tabs within the interface and the configuration options available in each: 

●     Menu: The Menu tab configures the general settings, including specifying a preset and determining the links that will be included 
in your menu.

●     Box: The Box tab configures the width, height, margins, and padding for the menu components.

●     Type: The Type tab controls the text properties, as described below the figure, for multiple text classes available for each menu 
component.

●     Design: The Design tab configures the background and border properties for each menu level component. 

Access

The following locations in Dreamweaver open the interface to create a new CSS Menu Writer menu: 

●     WebAssist Insert panel 
 

 
●     Insert > WebAssist > CSS Menu Writer > New Menu...

 
 
 
Wizard Reentry

After creating your Menu Writer menu, you may want to reenter the Wizard to make additional changes. To reenter the Wizard, follow 
these steps: 

●     Click the Design button to enter Design view.

●     Select your Menu Writer menu on your page.

●     From the Properties Inspector, click Edit.

 
Note: If you are using HTML or HTM pages, Dreamweaver must have Scripts set to display under Invisible Elements. You will then select 
this element for your menu, and click the Edit button from the Properties Inspector. 

●     Edit > Prefences.



 

Menu

The Menu tab configures the general settings, including specifying a preset and determining the links that will be included in your menu.  
 

 

Menu

Allows you to select a predefined style and design that you can use for your menus. Custom designs can be selected from here after being 
imported using the CSS Menu Writer Layout Manager. A number of preset styles have been designed for you to choose from, including 
various horizontal and vertical navigation menus. Each style varies in size, some extending the full width of the page, and others only 
extending as wide as the menu items require. 
 
Menu styles and designs can be further modified by changing settings in the Box, Type, and Design tabs. 
 

 

 
●     Style: Select from a number of preset styles, a custom style that you have imported, or select Last Custom Menu to retrieve the last 

menu style used. Selecting a style is a required step in creating menus.

●     Design: Select from a number of preset designs. Selecting a preset design is not a required step for creating menus. 

 
 
Presets

Presets refer to menu styles and designs that can be saved and made available each time you open CSS Menu Writer. 
 

 

 
●     Don't save a preset: When selected, no preset configuration will be saved when the Finish button is clicked.

●     Overwrite existing preset: When selected, the preset style selected will be overwritten with the current configuration.

●     Create new preset: Creates a new preset design to be accessed at anytime from the Style menu. When selected, enter the name for 
the new preset before clicking Finish.

●     Don't generate menu, but save preset: This option is only available when the Overwrite existing preset or Create new preset options 
are selected. When selected, the new preset will be saved, but the menu will not be generated and inserted onto your page.

 
 
Modifying your menu items

CSS Menu Writer allows you to customize which pages/links are included in your menu. 
 



Get from file system - Opens a file system dialog box allowing the user to specify a particular directory from which to retrieve the menu 
items. This will create a new node for all page files contained in the directory and each will be placed in the tree control relative to the 
currently selected node. 
 
Note: The Get from file system feature creates links based on your site root. Therefore, when using this feature you can only select files that 
are within your site root. 
 

 

 
●     Name: Name that will appear on the button.

●     Link: Page to be linked to when clicking on the button. 

●     Add: Adds a new node to the tree control and places it below the currently selected node.

●     Delete: Removes the currently selected node from the tree control.

●     Preview: Preview of all styles applied to the page.

●     Apply: Apply the changes specified on this tab.

 
 
Preview

The Preview pane displays a representation of the menu based on the configuration options you have specified. Clicking the preview displays 
the current menu in the user's primary browser. 

●     Preview: Preview of all styles applied to the menu. 

●     Apply: Apply the changes specified on this tab. 

 
 

   
 

  
 



 

Box

The Box tab configures the width, height, margins, and padding for the menu components. 
 

 

 

Menu Level control

Selecting a menu component within the control enables the corresponding property controls immediately below it, allowing you to configure 
the properties of that component directly. The following briefly describes the menu components and hierarchy used to design your menus: 
 

 

 

Dimensions

This section controls the width and height for the menu items. 
 

 

 
●     Width: Specify the width and select the units (if applicable) for the selected menu component. If a preset design is selected on the 

Menu tab, the width may already be defined.

●     Height: Specify the height and select the units (if applicable) for the selected menu component.

 
Margin and Padding

This section controls the margins and padding for a selected menu component. 
 

Margin: The additional space allocated outside of a menu component between that component and any others. 
 
Padding: The additional space allocated inside of a menu component between the border of that component. 
 
Options for specifying the Margin and Padding attributes are identical, and are detailed as follows: 

●     All: When selected, sets the same value for all sides of the component using the Top entry.

●     Top: Specify the top margin and select the units (if applicable) for the selected component.

●     Right: Specify the right margin and select the units (if applicable) for the selected menu component.

●     Bottom: Specify the bottom margin and select the units (if applicable) for the selected menu component.

●     Left: Specify the left margin and select the units (if applicable) for the selected menu component.  

Preview

The Preview pane displays a representation of the menu based on the configuration options you have specified. Clicking the preview displays 
the current menu in the user's primary browser. 

●     Preview: Preview of all styles applied to the menu. 

●     Apply: Apply the changes specified on this tab.



 

Type

This section controls the text properties, as described below the figure, for multiple text classes available for each menu component.  
 

 

Menu Level control

Selecting a menu component within the control enables the corresponding property controls immediately below it, allowing you to configure 
the properties of that component directly. The following briefly describes the menu components and hierarchy used to design your menus:  

 

Type:

This section controls the text properties, as described below the figure.  
 

 

●     Link: Applies to links that have not yet been visited.

●     Visited: Applies to a link once it has been visited by the user

●     Hover: Applies to an element while the user designates it with the cursor.

●     Active: Applies to an element when activated by a user. For example, between when the user presses the mouse button and releases 
it. 

Preview

The Preview pane displays a representation of the menu based on the configuration options you have specified. Clicking the preview displays 
the current menu in the user's primary browser. 

●     Preview: Preview of all styles applied to the menu. 

●     Apply: Apply the changes specified on this tab.

   
 

  
 



 

Design

This section configures the background and border properties for each menu level component. 
 

 

Menu Level control

Selecting a menu component within the control enables the corresponding property controls immediately below it, allowing you to configure 
the properties of that component directly. The following briefly describes the menu components and hierarchy used to design your menus: 

 

Background

The background section sets the properties for the background of a selected component. These properties are separated by several tabs: 
Color, Image Source, Image Repeat and Attachment, Image Position, Left Cap and Right Cap. 
 

 

●     Link: Applies to links that have not yet been visited.

●     Visited: Applies to a link once it has been visited by the user

●     Hover: Applies to an element while the user designates it with the cursor.

●     Active: Applies to an element when activated by a user. For example, between when the user presses the mouse button and releases 
it. 

 

 

li, span, and a

The background properties for the Link and Hover states of your menu items include options for <span> and <a>. These options are not 
available in Visited and Active states due to the cascading nature of CSS.  
 
<span>: Allows you to specify a right cap image to create a rounded edge appearance to your menu item. 
 
<a>: Allows you to specify a left cap image to create a rounded edge appearance to your menu item. 
 
<li>: Sets the background properties for the menu item.  
 
 

●     Color: Use the color-picker or enter the color value. The color value can be a color name (red) or a hex number (#ff0000).

Note: A background image will overwrite any background color. If your background color is not displaying, ensure that there is not 
background image inserted in either the <a>, <span>or <li>tabs. 



 
●     Filename: Use the browse icon or manually enter the http:// location for a background image. 

 
Note: If using different background images for the various states of your menu, these images must have different filenames 
irrespective of whether or not the images are stored in different directories. It is advisable that you store all images in the same 
directory before creating your menus.

●     Repeat: Sets how a background image will be repeated, if at all. Available options are: 

�❍     repeat: repeats the image vertically and horizontally

�❍     repeat-x: repeats the image vertically

�❍     repeat-y: repeats the image horizontally

�❍     no-repeat: does not repeat the image

●     Attachment: Sets whether the background image is fixed or scrolls.

●     Horizontal: Sets the position of the image horizontally. Available options are left, center, right, or a numeric value. Numerical values 
are entered directly with the following unit standards available for selection: pixels, points, in, cm, mm, picas, ems, exs, %

●     Vertical: Sets the position of the image vertically. Available options are top, center, bottom, or a numeric value. Numerical values 
are entered directly with the following unit standards available for selection: pixels, points, in, cm, mm, picas, ems, exs, % 

 
Border

This section sets the border properties for the selected menu component. You have the option of setting the same border properties for all 
four sides of a component using the All tab, or setting individual properties for each of the four sides of a component: top right, bottom, and 
left. Enabling properties in the All tab disables configuration in the other four tabs. The border column in the Menu Level control, when All is 
selected, displays shorthand for the border attributes applied. Otherwise, it will display top, bottom, right, or left for any tabs with 
information entered.  
 

 

 

Preview

The Preview pane displays a representation of the menu based on the configuration options you have specified. Clicking the preview displays 
the current menu in the user's primary browser. 

●     Preview: Preview of all styles applied to the menu. 

●     Apply: Apply the changes specified on this tab.

 

   
 

  
 



 

Layout Manager

The Layout Manger provides the ability to manage all the styles used in CSS Menu Writer. This can also be used to import custom styles, 
and export styles to be used in Menu Writer on other machines. 

Access

The following locations in Dreamweaver open the CSS Menu Writer Layout Manager: 

●     WebAssist Insert panel 
 

●     Insert > WebAssist > CSS Menu Writer > Layout Manager 
 

 
 
 
Layout Manager

 



 

 
●     New: Opens the CSS Menu Writer Menu allowing you to create a new style.

●     Edit: Opens the selected style in the CSS Menu Writer Menu allowing you to make any modifications. 

●     Duplicate: Creates a duplicate copy of the selected style. This appends the selected name with "copy". 

●     Remove: Removes the selected preset. 

●     Export: Exports the selected style to a .zip format allowing easy import into CSS Menu Writer on different machines. The .zip file 
contains an XML file describing the menu structure and any associated images. 

●     Import: Displays a Browse window allowing you to select a .zip file containing a CSS Menu Writer style to be imported.
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