
 

Working with Rounded Corner Layouts in CSS 
Sculptor 
Eric Meyer’s CSS Sculptor 2 or higher includes three layouts that feature 
rounded corners.  These rounded corners use images to create the rounded 
effect, and therefore customizing this design requires a little more work. 

This How To shows you how to customize a rounded corner design to 
incorporate the following: 

• Rounded corner top navigation div 

• Custom widths and heights for various elements 

• Customized color scheme, including Type modifications 

What Do You Need to Start?  

• Eric Meyer’s CSS Sculptor 

• Dreamweaver CS3 or CS4  

• Adobe Fireworks 

• Rounded Corner PNG Designs - Available in your Download Center 

• Sample Completed Sculptor design (for reference) 
Import RoundedCorners_TopNav_Sculptor.zip file into the CSS 
Sculptor Preset Manager. 

 



Downloading the Rounded Corner PNG designs 

For help in customizing your Rounded Corner layouts, we have provided PNG 
image files that can be easily editing within Fireworks.  These are located in 
your Download Center.  

1. Go to http://webassist.com/go/downloads 
You will be asked to log in with your account details. 

2. Select the Eric Meyer's CSS SCULPTOR option. 

3. Download the Rounded Corner Source Files. 

4. Extract the contents of the download .zip file. 

This .zip file contains the PNG source files for the three Rounded Corner 
layouts. 
For this demonstration we will be working with the 2 Column Fixed, 
Rounded Corner, Left Sidebar, Header and Footer PNG. However, 
you can apply the techniques used here for the other options.  

Customizing your design in Fireworks 

The first step to modifying the rounded corner design is to use Fireworks to 
create our new images. 

1. Open the 2 Column Fixed, Rounded Corner, Left Sidebar, Header 
and Footer PNG source file in Fireworks. 
Many of the steps discussed here will apply to other image editing 
applications. 

Notice that in the Frames panel for CS3, or States panel for CS4 users, 
that an option for each color scheme has been provided.  If you would like 
to modify a particular color scheme, you can choose that now. For this 
example, we will be changing all colors, and will not need to choose a 
particular color scheme. 

2. Display the Layers panel, by choosing Window > Layers. 

3. Uncheck the visibility option for the Web Layer, fill – white, text 
dark, and primary layers. 
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We do this to hide the layers that we will not be modifying at this time.  
This will help make the other elements easier to work with. 

Setting your Ruler 0-point 

This step is required to ensure accuracy when assigning coordinates for our 
div elements in this How To. 

1. Click and drag from the top right corner of the ruler to expose the two 
dotted lines. 

  

2. Make the intersection of the dotted lines match up with the top left 
corner of the design, as shown in the picture above. 

Resizing the Header div 

1. With the Pointer tool selected, click once on the Header div. 

2. In the Properties Inspector, replace 129 in the Height field with 79. 

 

Resizing the Left Column 

1. With the Pointer tool selected, choose the Left column div. 
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2. In the Properties Inspector adjust the width to 214. 

3. Adjust the X coordinate value to 38. 

 

Resizing the Content div 

1. With the Pointer tool selected, choose the Content div. 

2. In the Properties Inspector adjust the width to 593. 

3. Adjust the X coordinate value to 261. 

Creating the Top Navigation div 

1. Select the Rectangle tool from the Tools panel. 

 

2. Click and drag a rectangle over the empty space beneath the Header 
div. 
You do not need to precise with the dimensions of your rectangle as 
we will adjust that next. 

3. In the Properties Inspector enter 815 for the width, and 42 for the 
height. 

4. Enter 38 for the X coordinate value. 
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5. Enter 96 for the Y coordinate value. 

 

6. Use the Roundness option from the Properties Inspector to apply the 
desired rounded effect on your corners. 

 

Modifying the Background 

1. With the pointer tool selected, click once on the gray background. 

2. In the Properties Inspector, set the Roundness to 0. 

Modifying the color scheme 

1. With the Pointer tool selected, select the background color. 

2. From the Properties Inspector select the color picker. 
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3. Choose #999999 from the color swatch. 

 

4. Click once to select the Header div. 

5. From the Properties Inspector select the color picker. 

6. Choose #AE0000 for the color. 

7. Select the top navigation div. 

8. From the Properties Inspector select the color picker. 

9. Choose #CCCCCC for the color. 

10. Select the left column div. 

11. From the Properties Inspector select the color picker. 

12. Choose white (#FFFFFF) for the color. 

13. Select the content div. 

14. Choose #333333 for the color. 

15. Select the footer div. 

16. Choose #AE0000 for the color. 

Creating the slices 

Slices have already been created for most of our elements, but due to our 
additions and changes, we need to move some slices, and create some new 
ones. 

1. To display all slices, check the visibility option for the Web Layers 
option in the Layers panel. 
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Slices will be indicated by light green shading. 

2. With the Pointer tool selected, click once to select the header_bg slice. 

3. Click and drag the slice to the center of the header div, ensuring that 
the rounded corners are not included in the slice. 
Be careful not to move the slice left or right when dragging. 

4. Select the header_bottom slice. 

5. Click and drag the slice to cover the bottom portion of the header div, 
and the top portion of the top navigation div. 

 

6. With the header_bottom slice still selected, press Ctrl (Cmd) + C, to 
copy this slice. 

7. Press Ctrl (Cmd) + V, to paste the slice. 

8. Click and drag the slice to cover the center of the top navigation div, 
making sure not to include the rounded corners. 

 

9. In the Properties Inspector, enter topnav_bg for the name. 

 

10. With the topnav_bg slice selected, press Ctrl (Cmd) + C to copy 
this slice. 
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11. Press Ctrl (Cmd) + V, to paste the slice. 

12. Drag the slice to cover the bottom portion of the top navigation div, 
and the top portion of the left column and content divs. 

 
Be sure to include the entire rounded corners for the slice to be 
accurate.  You may need to increase the height of the slice to do this. 

13. In the Properties Inspector enter topnav_bottom for the name. 

Since we did not make any other changes to the content or footer divs, 
we can leave those slices as is. 

Exporting the slices 

1. From the File menu, choose Export. 

2. Locate the directory you would like to use to store these slices. 

3. From the Export menu list, choose Images Only. 

4. From the Slices menu, make sure Export Slices is selected. 

5. Uncheck Selected slices only. 

6. Select Current state only (CS4) or Current frame only (CS3). 

7. Make sure Include areas without slices, and Current page only are not 
selected. 

 

8. Click Save. 

When you press Save, Fireworks creates images for all the slices that you 
have defined, and names them based on the names you provided. 
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Creating a new design in Sculptor 

The next step is to create your CSS Sculptor layout. We will do this by 
starting with a preset Rounded Corners layout, and modifying it to use our 
new images, and include our top navigation. 
Before you begin, make sure you have defined your site in Dreamweaver. 

1. From the Dreamweaver File menu, choose New CSS Sculptor Page. 

2. From the Design menu, choose 2 Column Fixed, Rounded Corner, 
Left Sidebar, Header and Footer. 

3. Choose the Customize CSS button. 

4. Select the top navigation checkbox. 
If you click Apply, the top navigation div will be displayed at the top of 
the design, without rounded corners.  We will fix this next in the Box 
and Design tabs. 

5. Choose the Box tab. 

Note: You may notice when working with Rounded Corners in Sculptor that 
various features do not function as expected. This is due to the use of images 
to create the rounded corners effect. By following the steps in this How To, 
and creating any necessary slices, you should be able to create any Rounded 
Corners design you would like. 

The Box tab 

In the Box tab we will create new div elements for use with our top 
navigation div as well as move elements to the necessary location within the 
CSS. 

6. Select the topNavigation div from the Layout tree. 

7. Click the down option once to move the topNavigation div below the 
headerBackground element. 

8. Click once on the Add icon to create a new div. 
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9. In the name field enter TopNavbg. 

10. Click again on the Add icon. 

11. In the name field enter TopNavbottom. 

12. Select the TopNavbg div. 

13. Select the move left option to move this div to the left. 

14. Select the topNavigation div. 

15. Select the move down option to move this below to the 
TopNavbottom div. 

16. Select the move right option to move the topNavigation div to be 
the outer-most option within TopNavbg. 

 
Take note of the positioning of the div elements.  The topNavigation 
div, which will contain the placeholder text for the navigation must be 
the outer-most div for the top navigation. 

17. With the topNavigation div still selected, click the Padding tab. 

18. In the Top field enter 5 pixels. 

19. In the Right field enter 45 pixels. 

20. In the Bottom field enter 30 pixels. 

21. In the Left field enter 45 pixels. 
These adjustments are necessary to align the Top Navigation content 
with the topNavigation div. 

22. In the Layout tree, select contentWrapper. 

23. Choose the Padding tab. 

24. Enter 30 pixels in the Right field. 

25. Select the LeftColumn1 div. 

26. In the Width field, enter 195 pixels. 
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27. In the Padding tab, set the following padding: 

• Top: 10 pixels 

• Right: 10 pixels 

• Bottom: 14 pixels 

• Left: 35 pixels 

28. Select the content div. 

29. In the Padding tab, set the following padding: 

• Top: 14 pixels 

• Right: 20 pixels 

• Bottom: 14 pixels 

• Left: 14 pixels 

30. Select the headerBottom div. 

31. Enter 115 pixels in the Height field. 

32. Select the Type tab. 

The Type tab 

In the Type tab, we will choose the colors we would like to use for our 
various text elements.  

1. Click once to select the body tag. 

2. From the Text tab, select the color picker. 

3. From the color picker, choose white (#FFFFFF). 

 

4. Choose the h2 tab. 
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5. From the color picker, choose dark gray (#333333). 

 

6. Choose the Link tab. 

7. From the color picker choose dark red (#AE0000). 
You may also want to set the colors for Visited, Hover, Focus and 
Active. 

8. Select the topNavigation div. 

9. Choose the Text tab. 

10. From the color picker, choose dark gray (#333333). 

11. Select the leftColumn1 div. 

12. From the color picker, choose dark gray (#333333). 

13. Choose the Design tab. 

The Design tab 

In the Design tab, we will change the images used in this design to use our 
new images. 

14. Select the body tag. 

15. From the Background color picker, choose light gray (#999999). 

16. Choose the headerBackground div. 

17. Select the Image Source tab. 

18. Choose the Filename Browse option. 

19. Navigate to the directory that you exported your slices to. 

20. Select header_bg.gif. 

21. Click OK. 
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Dreamweaver may alert you that you should save your file first. Simply 
click OK when you see this message. 

22. When asked to copy the file to your site click No.  
Sculptor will copy all the necessary image files to your site when 
creating the layout. 

23. Select the headerBottom div. 

24. Choose the Filename Browse option, and select 
header_bottom.gif. 

25. Click OK. 

26. Select the headerTop div. 

27. Choose the Filename Browse option, and select header_top. 

28. Click OK. 

29. Select the TopNavbg div. 

30. Choose the Filename Browse option, and select topnav_bg.gif. 

31. Click OK. 

32. Choose the Image Repeat and Attachment tab. 

33. From the Repeat menu, choose repeat-y. 

34. Select the TopNavbottom div. 

35. Choose the Image Source tab. 

36. Choose the Filename Browse option, and select 
topnav_bottom.gif. 

37. Click OK. 

38. Select the Image Position tab. 

39. From the Vertical menu, choose bottom. 

40. Select the topNavigation div. 

41. Choose the Color tab. 
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42. Select the color picker, and choose the Default color. 

 

43. In the Border section, choose Bottom. 

44. Choose the blank option under Style. 

 

45. Delete the width value. 

46. Choose Default color from the color picker. 

47. Select the contentWrapper div. 

48. Select the Image Source tab. 

49. Choose the Filename Browse option, and select 
contentwrapper_bg.gif. 

50. Click OK. 

51. Select the footerBackground div. 

52. Choose the Filename Browse option, and select footer_bg.gif. 

53. Click OK. 

54. Select the footerBottom div. 

55. Choose the Filename Browse option, and select 
footer_bottom.gif. 

56. Click OK. 

57. Select the footerTop div. 

58. Choose the Filename Browse option, and select footer_top.gif. 

59. Click OK. 

60. Click Apply to see your changes in the Preview window. 
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61. Select the body tag. 

62. Choose the Color tab. 

63. Select the color picker and click once on the gray background in the 
preview window. 

64. Click Apply. 

65. Continue making changes or choose Finish to create the page. 
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