
 

CSS Form Builder Getting Started Guide 
CSS Form Builder gives you the ability to create a form from scratch, modify 
an existing form, and customize the entire appearance. 

This Getting Started Guide will demonstrate how to use CSS Form Builder to 
create a new form from scratch.  Additionally, the necessary steps for 
applying spry validation will be highlighted. 

What Do You Need to Start?  

• Dreamweaver CS3 or CS4 

• CSS Form Builder 

• Spry framework for Ajax (Dreamweaver CS3 only)* 
http://labs.adobe.com/technologies/spry/ 

*CSS Form Builder utilizes the latest Spry framework for Ajax that is included in 
Dreamweaver CS4. If you own Dreamweaver CS3, this Spry framework will not be 
included, and needs to be installed separately prior to using CSS Form Builder. 

 

Installing your extension 

The first step to getting started with your purchase is to install your 
extension. All WebAssist Dreamweaver extensions are installed through the 
Adobe Extension Manager. 

Follow the instructions found in the following two TechNotes for downloading 
and installing the extension. 

• Downloading extensions and files 

• Installing WebAssist extensions 

 

Do you have a Dreamweaver site defined? 

Before you can use CSS Form Builder you will need to have defined a site in 
Dreamweaver so that Form Builder knows where to save the various files it 
creates. 

If you haven’t yet defined a site in Dreamweaver, review the Dreamweaver 
Simulation available from the Getting Started with Dreamweaver tutorials. 

 

http://labs.adobe.com/technologies/spry/
http://www.webassist.com/go/technotes/download
http://www.webassist.com/go/technotes/install
http://www.webassist.com/training/resources.php#tab2


What do you want to create with CSS Form Builder? 

CSS Form Builder allows you to design and create a form faster than you can 
do it by hand, or using the functionality provided in Dreamweaver.  However, 
you will probably need to use another WebAssist extension, to add certain 
desired functionality to your form.   

For example, if you wish to create a contact form, you can use CSS Form 
Builder to design your form and add validation, but in order for that form to 
be able to send an email you will need to apply certain functionality using 
Universal Email. 

Creating a Contact Form 

After creating your contact form with CSS Form Builder, you will need to 
follow the Universal Email Getting Started Guide to apply the email 
functionality to your newly created form. 

Note: If you do not own Universal Email, you can also purchase the Contact 
Form Solution Pack which includes a pre-built Contact Form.  Simply refer to 
the Modifying an Existing form with CSS Form Builder instructions to modify 
this contact form to look as you would like. 

Modifying a form that you have already created 

CSS Form Builder can also modify existing forms.  This allows you to take a 
form that already contains the desired functionality, and use CSS Form 
Builder to customize the design, or apply navigation or new form fields.  
Forms created by products such as DataAssist, eCart and SecurityAssist, can 
simply be modified by CSS Form Builder.   

For instructions, refer to the Modifying an Existing Form steps included in this 
Getting Started Guide. 
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Starting with CSS Form Builder 

Form Builder can be used in a variety of different ways depending on what 
you aim to achieve. You may be planning on modifying an existing form, 
creating a new form from scratch, or creating a form out of a preset design.  

Starting from scratch 

1. Open the PHP page you wish your form to be inserted to. 

2. Place your cursor where you wish your form to be added. 

3. Enter the CSS Form Builder by choosing Insert > WebAssist > CSS 
Form Builder > Insert Form. 

Modifying an existing form 

CSS Form Builder will inspect an open document for form elements and will 
create a new form to be customized within the Form Builder interface. 

Note: When CSS Form Builder imports your form fields, it only records the 
name and id of each of the form elements. Within Form Builder, you will need 
to specify the type of form element each imported element will be.   

Read the following How To for instructions on accomplishing this: 
How to modify a custom form in CSS Form Builder 
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http://www.webassist.com/go/howto/fb_custom_form


Choosing a form type 

CSS Form Builder includes five different categories of pre-configured forms 
for you to choose from. To speed up your form creation process, it is often 
easier to create a form from one of these presets, and then use the Form 
Builder interface to further customize that form. 

1. From the menu list, choose the type of form you wish to create. 
Choose <New From Blank> if you wish to create a brand new form. 

2. Choose a desired set of form elements from the second menu list. 
Use the preview to determine which option provides the closest match 
to the form fields you need. 

Choosing a design 

CSS Form Builder allows you to choose from 4 different preset designs. Each 
option includes a different design for text fields, Captcha, as well as other 
form elements. 

Note: Once you have created your own custom design for your form and its 
elements, you can save it as an additional preset to be available here. 

3. From the design menu list, choose a desired design. 

Note: The secondary design menu list will only be available once you 
save a custom menu. 

Specifying an action page 

In the action page field, you will enter the page that this form is to submit to. 
Most forms submit to themselves, therefore the current page will be selected 
by default. 

4. Choose the browse option or manually enter the filename and path for 
the file that this form is to submit to. 

Select the form method 

Forms can be submitted through one of two different methods. By default, 
POST has been selected as it is the most secure and will work for most types 
of form.   

The following describes which method to use: 
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POST - Should be used for most forms. This option is most secure since it 
does not display any values in the URL field after submitting. 

GET - This method will includes the various values entered into the URL field 
when submitted. This is useful in situations where you might want to allow 
for bookmarking the resulting page. 

Now that you have specified these four options, you can click Finish to 
have your form created. However, if you wish to modify this form in 

any way, including adding form fields, or modifying the design, continue with 
the rest of this document. 
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Customizing form elements and modifying validation 

The Edit Form interface of CSS Form Builder allows you to modify each 
individual form element, configure validation, and rearrange the layout of 
your form. 

1. Access the interface for customizing your form elements, by choosing 
the Edit option under ‘Choose a form’. 

 

In this interface, the various form elements are organized by groups, 
where each group contains one or more form elements. Each group is 
managed within a Fieldset. 

2. Change the label of a fieldset by selecting the fieldset and modifying 
the options below. 

3. Select each group individual to modify the options for each group. 

4. Choose from the category menu to choose the category you wish to 
use for the selected group. 

Selecting a category is the quickest way to customize which form 
fields appear on your form without having to manually configure the 

validation. To save time you might want to create groups that contain the 
fields you want, and just delete any fields that are not needed. 

 

5. Add any additional groups by clicking Add > Element group 

 
The new group will be added directly beneath the currently selected 
group. 
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6. Add a new fieldset by selecting an existing fieldset and clicking Add > 
Fieldset. 

 

Modify individual form elements 

If desired, you can modify each individual form element by following these 
steps. This is where you have the ability customize the validation error 
messages, and what type of validation is applied to each element. 

1. Select the group that contains the elements you wish to modify. 

2. Choose Edit. 

On this page, each group is broken down into lines which are further 
broken down into sets. A line is an actual line on the page, and a set often 
consists of multiple form elements, that share the same label. 
For example, ‘Name’ is commonly in the same set, but contains two text 
fields (first name and last name). 

Note: A set shares the same validation error message.  Therefore, if one 
of the form fields in a set fails, the same error message will display. 

3. To customize the validation error message, select a set from the tree, 
and enter your desired message in the window. 

Changing the form type 

4. Select a field from the tree. 

5. From the options available below, complete the following. 

• Label: Enter the label (if any) 

• Type: Choose the type of form element you wish to be created. 

Note: To protect your form from being completed by web robots, Captcha 
and Security Question options are provided under the Type menu.  These 
two options do not have validation options. 

Applying validation 

6. For the selected form element, configure the following. 
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• Required: Select if this form field must be completed to pass 
validation. 

• Validation-Type: Choose the type of validation you wish to be 
applied to this field. 

Note: CSS Form Builder automatically creates the necessary validation 
for the type of validation selected. 

4. Once you have specified all the settings for that form element, repeat 
the process with all other form elements within the tree. 

5. Choose Finish when you have made all your changes. 

After choosing Finish, you will be prompted to save a preset.  This 
will allow you to quickly use these same settings to create additional 

forms in the future. 

6. Continue making additional changes to the groups or Fieldsets. 

7. Click Finish when you are done. 

 

 

Customizing the Form Design 

CSS Form Builder includes four preset designs for you to use. Each design 
can be modified to suit your needs, but is offered as a good starting point to 
achieve the attractive form you want. 

1. From the primary CSS Form Builder interface, choose Edit next to the 
design options. 

 

The Edit Design interface provides you with the necessary options for 
customizing each aspect of your form. 

2. Choose from the menu list the aspect of your form you wish to design. 
For some options, an additional menu list will appear. 
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3. Each option includes different settings allowing you to completely 
modify each aspect of a form. 

To save time, you may only want to modify the design for the 
elements that appear on your page.  For example, if you are not 

using Captcha, you may not want to devote the time to customizing its 
appearance. 

4. Proceed through each option, modifying the settings to appear as 
desired. 

5. Click Apply to update the preview as you make changes. 
To test changes to validation messages and date picker designs, you 
will want to preview your form in a browser by clicking on the Preview. 

6. When you are finished, click Finish. 

7. If desired, save a preset so that you can use your same design for 
other forms.  

8. When ready, click Finish to have your form created. 

CSS Form Builder will insert the form where your cursor is placed on the 
current page.   

You may find additional files and folders have been added to your 
Dreamweaver site.  All of these files are necessary for your form and 
validation to work properly. 
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