
Getting Started with Eric Meyer's CSS Sculptor 1.0 
Eric Meyer’s CSS Sculptor is a flexible, powerful tool for generating highly 
customized Web standards based CSS layouts. With CSS Sculptor, you can 
quickly create a cross-browser compatible layout with custom widths, 
margins, paddings, background images and more. 

CSS Sculptor is comprised of two key interfaces: one for creating a new page 
and the other for managing preset layouts.  

• Creating a Layout 

• Managing Layouts 

Each interface can be accessed in a couple of ways. You can begin to create a 
layout by any of these methods: 

• Choose File >  New CSS Sculptor Page. 

 

• Choose Insert > WebAssist > CSS Sculptor > New Page. 

Likewise, the CSS Sculptor Layout Manager can be invoked by the following 
technique: 

• Choose Insert > WebAssist > CSS Sculptor > Layout Manager. 
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Creating a Layout 
CSS Sculptor creates a wide range of CSS-based layouts, all Web standards 
compliant and cross-browser compatible. With CSS Sculptor, you can 
customize your layout as much as you’d like and immediately output your 
layout complete with CSS styles for both screen and print. 

The CSS Sculptor interface has six tabs. Each of the first 5 tabs controls a 
particular set of CSS properties for the page to be generated:  

 

• Layout – Determines the initial layout of the page, either by choosing 
a preset layout or by selecting the layout elements manually, including 
the number of columns to use in the content area and an optional top 
navigation area. The Layout tab also provides a series of design 
presets which control the basic color scheme. You also have the option 
of modifying the page structure on the Layout tab by changing the 
width, position, minimum width, and maximum width properties. 

• Box – Sets the width and height of any layout component, as well as 
individual margin or padding values. The Box tab also provides a 
method for renaming the ID for any major <div> tag. 

• Type – Use the Type tab to determine a wide range of properties for 
basic text, h1-h6 tags, and a series of pseudo-classes (link, visited, 
hover, focus and active). Properties available include font-family, font-
size, color, decoration, and weight. 

• Design – The Design tab makes it possible to define the full set of 
background and border properties for any layout component.  You 
could, for example, add a background image to a header, set the 
repeat property to no-repeat and even position it horizontally and 
vertically. 
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• Print – Modifies your screen CSS settings to create a style sheet for 
print. Global settings allow you to quickly set all <div> tags to auto 
and colors to black and white—or you can change these settings 
individually for each layout component.  You can also optionally hide or 
zero out margins and paddings for any area. 

The final tab—Output—is used for defining the output options including the 
destinations for screen and print CSS styles (embedded or in an external 
style sheet), the degree of placeholder content and comments, and the 
creation or overwriting of a layout preset. 

In the next section, you’ll begin to use CSS Sculptor to create your layout 
structure. 
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Choosing and modifying a preset layout 
The first tab of CSS Sculptor, Layout, establishes the basic page structure. 
CSS Sculptor includes a collection of 30 different preset layouts to help you 
get started—or you can create your own. Any layout can be easily modified in 
a number of ways, including width and page position. Additionally, a second 
set of presets, Design, initially controls the overall look-and-feel of the 
layout.  

Note: Throughout this Getting Started Guide, I’ll choose a particular option 
or enter a set value. You’re free to experiment on your own and try different 
options; however, the screen shots in the Guide may not match your choices. 

To choose and modify a preset layout: 

1. Open CSS Sculptor by one of the following methods: 

• Choose File > New CSS Sculptor Page. 

• Choose Insert > WebAssist > CSS Sculptor > New Page. 

• From the Insert bar, switch to the WebAssist category and click 
New CSS Sculptor Page. 

• Right-click on any document tab and choose New CSS Sculptor 
Page. 

2. When CSS Sculptor opens, choose a preset from the Layout list. For 
this demonstration, I’ll choose 2 Column Liquid, Left Sidebar, 
Header and Footer. 
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Once you choose a preset, a number of CSS properties are populated 
with the associated values, some of which are visible in the Layout 
tab. If you just wanted to create a simple layout, you could, at this 
point, click Finish. 

The preset layouts are divided into four different types: 

• Fixed – Page and columns widths are set with pixels and do not 
resize if the browser window or browser text size changes. 

• Liquid – Page and column widths are set with percentages which 
allows them to resize when the browser window changes. 

• Elastic – Page and column widths are set with ems which allows 
the columns to resize when the browser text size changes. 

• Hybrid – Page widths are set with a percentage and columns with 
ems. This combination allows the overall page width to change as 
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the browser window changes and the columns to change when the 
browser text size changes. 

Note: While it’s possible to create any common Web page layout 
from scratch within CSS Sculptor, it’s much faster to start your 
design with a preset layout. As you’ll see later, you can easily save 
your own presets to select them as custom starting points. 

3. If you want to work with an overall color scheme, choose an entry 
from the Design list. I’ll select Pacifica. 

The 11 color schemes in CSS Sculptor are also available in other 
WebAssist products like SiteAssist, DataAssist and SecurityAssist for 
a consistent look-and-feel. 

4. As you can see in the Page structure section, the preset width for this 
layout is 80% and centered. Let’s leave those values as is and add a 
minimum width. In the Min Width field, enter 760 and leave the 
unit list set to pixels. 

 

The min-width and max-width properties is a CSS 2.0 property and 
are not supported in older browsers (such as Internet Explorer 6), 
but do work in Firefox, Internet Explorer 7, and Safari, among others.  

5. Let’s try out the new setting. Click the Preview to display the layout 
in your primary browser. Change the width of your browser window 
to note how the layout remains centered and at 80% of the width of 
the window—until the window is less than 760 pixels wide. Close your 
browser and return to Expression Web. 

One of the hallmarks of CSS Sculptor is its extreme flexibility. Let’s 
explore this advantage in the Layout component section. 

6. Change the Left column value to 2. 
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CSS Sculptor adds a new column to page as requested. If that’s not 
exactly what you had in mind, you can change your mind. 

Note: When you add a new column next to an existing column as 
we’ve done in the above step, CSS Sculptor picks up the properties of 
the existing column. If you add a new column where one did not exist 
before—by changing a column value from 0 to 1 or more—default 
column properties are used. 

7. Change the Left column value back to 0. 

CSS Sculptor is designed to be flexible and quick, so you can modify just the 
properties you want and click Finish at any point. You could, for example, 
click Finish here to create the existing page and accompanying CSS. 
However, there is so much more possible with CSS Sculptor; in the next 
section, you’ll modify the basic box properties such as width and height as 
well as change the margin and paddings of individual layout components. 
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Adjusting the Box properties 
The box, in CSS, is a basic building block. CSS Sculptor uses <div> tags for 
each layout component; each <div> tag has a unique ID, like header or 
footer. The Box tab in CSS Sculptor allows you to change the ID and various 
box-related properties (like margins and padding) for each layout 
component. 

The Box tab also introduces a user interface element common to a number of 
the other tabs in CSS Sculptor, the layout tree. The layout tree shows each 
individual layout component used to structure the CSS for the page. In 
addition to the elements specified on the Layout tab, like content or header, 
a few other elements are displayed to make the CSS work properly. These 
additional elements include: 

 

• body – The body tag is at the top of the layout tree and is made 
available to change margins and padding in the Box tab; in other tabs, 
select the body entry to specify a different overall font-family, text 
color or background color. 

• outerWrapper – The outerWrapper encompasses all of the <div> 
tags used to construct the page. A common use of the outerWrapper is 
to center the layout by setting the left and right margins to auto.  

• contentWrapper – As the name implies, the contentWrapper 
surrounds the main content area, including any columns. Select the 
contentWrapper when you want to modify properties for both content 
and column(s). 

Because the layout tree displays the CSS structure properly, you can more 
easily get a sense of what elements are contained within each other. For 
example, if you collapse the contentWrapper entry in the example, you’ll see 
just the core elements within the outerWrapper: header, contentWrapper, 
and footer. 
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To modify the Box properties: 

1. From the layout tree, choose outerWrapper. 

First, let’s add a bit of space between the top of the browser window 
and the layout. 

2. In the Margin subtab, make sure the All checkbox is deselected and 
enter 50 in the Top field and select pixels from the unit list. 

 

 

 

Notice that the outerWrapper Margin column is updated in the tree 
control to read 50px auto 0 auto. This is CSS shorthand that can be 
read “set the top margin to 50 pixels, the right to auto, the bottom to 
0 and the left to auto.” CSS Sculptor uses proper CSS shorthand 
throughout the interface to tell you your settings at a glance. 

A bit later in this exercise, you’ll add a background logo to the 
header. To accommodate the image, let’s expand the width of the 
header. 

3. Select header from the layout tree and, in the Height field, enter 75 
with pixels selected in the unit list. 
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You can also change the names of any layout component (except for 
the body tag). 

4. From the layout tree, select leftColumn1, change the Name field to 
sidebar and press Tab. 

The <div> tag for the left column will now use an ID of sidebar. Now, 
let’s customize content area a bit. 

5. From the layout tree, select content. 

6. Click the Padding subtab and deselect the All checkbox. 

When the All checkbox is selected for either the Margin or Padding 
subtabs, the value in the first field controls the values for all fields. 
For example, with All selected, if you enter a 25 in the first Padding 
field (top), the remaining properties (right, bottom and left) will also 
be set to 25. Deselect the All box when you want to enter individual 
property values. 

7. Change both the Left and Right field values to 20. 

The main content area now has a bit more white space on the left 
and right sides.  
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Next, you’ll learn how you can customize the text for your layout in the Type 
tab. 
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Setting the Type 
Text plays a large role in the look-and-feel of any Web page. CSS Sculptor 
gives you the power you need to completely customize the font properties for 
standard paragraphs, headings and the various link states. 

Note: CSS Sculptor includes a pseudo-element that is frequently omitted 
from the typical series of link states, a:focus. The a:focus pseudo-element is 
typically applied when a link receives focus in a browser, either by being 
clicked or tabbed to. The order of the link subtabs (link, visited, hover, focus, 
active) is significant and reflects the order in which the code is written. 

To set the type properties: 

1. In the layout tree, select the body entry. 

2. From the Text subtab, choose Palatino Linotype, Book Antiqua, 
Palatino, serif from the Font list. 

3. In the Size field, enter 12 and, in the Line Height field, 16. Click 
the preview image to see the changes in your browser. When you’re 
done, close your browser and return to Expression Web. 

 

You can also modify the text properties for a particular page area. 
Let’s change the headings for just the main content. 

4. From the layout tree, select content. 

5. Click the h1 subtab and, from the Font list, choose Arial Black, 
Gadget, sans serif. Set the Size field to 18 and then, in the the 
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Color swatch field, enter the hexadecimal value #353C48—which 
corresponds to the dark blue of the body. 

 

You can also specify link properties. 

6. From the layout tree, select sidebar. 

7. Click the Link subtab and click the Color swatch. Again, enter the 
hexadecimal value #353C48 in the Color field. Click the preview 
image to examine the links in your browser. Close the browser and 
return to Expression Web when you’re done. 
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This particular design calls for an underline decoration on the hover 
state (set on the body tag). You could easily change that here if you 
liked. 

In the next section, you’ll learn how to add background images and borders 
to any layout component. 
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Inserting Design elements 
Background images and borders are integral to modern CSS layouts. CSS 
Sculptor makes it possible to add a background color and/or image, along 
with complete background properties to the body tag or any individual layout 
component. In addition, borders can be applied to surround any element or 
along any side. 

To add a background image: 

1. Click the Design tab. 

2. In the layout tree, select header. 

3. From the Background Color subtab, delete the hexadecimal entry in 
color field. Alternatively, you can click the color swatch and choose 
the Default Color icon. 

 

The background color is removed to allow the background image to 
show through. 

4. Click the Image Source subtab.  

5. Click the Filename folder icon and, when the Select Image Source 
dialog box opens, choose your file. For this demonstration, I’ll choose 
the Blue Sky Music logo, which measures 160 x 71. 

You'll notice that the logo is repeated in the header area; this is the 
expected behavior for an background image. However, you can 
specify a property to make it appear only once.  

 Page 15 



Eric Meyer’s CSS Sculptor
   

6. Switch to the Image Repeat and Attachment subtab and choose 
the desired option from the Repeat list. For this demonstration, I’ll 
choose no-repeat. 

7. To position your image within the containing element, click the 
Image Position tab. Here, I’ll set the Horizontal field to 20 pixels 
and the Vertical field to 15 pixels. 

 

Let’s give the footer a more distinct, separated appearance by applying a 
thick border. 

To apply a border: 

1. From the layout tree, choose footer. 

You’ll need to scroll down the layout component pane to locate 
footer. 

2. In the Border area, make sure that the All checkbox is not selected 
and click the Top subtab. 

3. Leave the Style list set to solid and change the Width field to 20 
pixels. In the color swatch field, enter the hexadecimal value 
#353C48. 

4. Click the preview image to review in your browser. 
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Your screen style are now complete. In the next step, you’ll define the styles 
for a print style sheet. 
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Crafting the Print style sheet 
Modern browsers render the print style sheet when the Print Preview or Print 
command is issued. Many designers attempt to optimize their print style 
sheets for the more suitable print format, which typically expands the 
divisions to full width and reduces the color scheme to black and white. 
Additionally, certain areas – such as those which contain linked navigation – 
are hidden. CSS Sculptor allows you to set up such a style sheet quickly and 
easily. 

To create a print style sheet: 

1. Click the Print tab. 

2. In the Global section, click the Convert divs to page width 
checkbox, the Convert divs to black and white checkbox, and the 
Set margins and padding to zero checkbox.  

 

CSS Sculptor applies the most commonly expected print changes to 
all layout components. Let’s say, however, you want to display the 
logo that is in the header area. CSS Sculptor gives you the option to 
make your changes not quite global. 

3. In the Global section, deselect the Convert divs to black and white 
checkbox. 
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This action re-enables the Convert the black and white option in the 
Display section which allows individual layout components to be 
restored to color. 

4. In the layout tree, select header.  

5. In the Display section, uncheck the Convert the black and white 
checkbox.  

 

 

It’s just as easy to hide a section of the page. 

6. In the layout tree, select footer. 

7. In the Display section, select the Hide checkbox.  

 

Note: If you click the preview image, the page will display as shown 
in the Print tab preview pane and not as the screen style sheet is 
defined. To see the print style sheet in its intended usage, you’ll need 
to click Finish and preview the page in the the Expression Web 
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standard browser and then choose your browser’s Print Preview 
command. 

With both screen and print styles defined, it’s time to establish your output 
options. 
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Determining output options 
The final tab of CSS Sculptor gives you control over the resulting documents 
and the option to save your preset. Your CSS code—for either screen or 
print—can be stored however you prefer: embedded in the HTML page, as a 
new style sheet or incorporated into an existing style sheet. Other options 
include the ability to set a doctype for the HTML page, determine the amount 
of placeholder content, and include or omit CSS comments. Another key 
feature is the ability to save a new preset or overwrite the current one. This 
makes it easy to quickly re-generate layouts with minor or major changes. 

To set the output options: 

1. Click the Output tab. 

2. Choose where you’d like to store your CSS screen styles from the 
Screen list. For this exercise, I’ll choose Embed in <head> to 
maintain the styles in the HTML page. 

3. Choose where you’d like to store your CSS print styles from the Print 
list. I’ll choose New Style Sheet and click the folder icon to pick a 
folder location and file name in my site. 

 

4. To set the amount of placeholder content to include in your 
generated layout, choose one of the options from the Placeholder list: 

• Full – Includes full lorem ipsum style placeholder text as 
displayed in the CSS Sculptor previews. 

• Minimal – Applies one sentence for each div. For example, 
“Content for header div goes here.” 

• None – Removes all placeholder content. 

For this demonstration, I’ll keep the Placeholder option at Full. 

5. If you’d like to remove comments from your CSS code, deselect the 
Include CSS comments checkbox. 
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6. In the Page Generation section, choose your doctype from the 
Doctype list. The default is XHTML 1.0 Strict. 

The Don’t generate page or styles, but save preset option is useful when 
creating a library of presets or editing an existing preset where no page is 
needed immediately. 

To save a preset: 

1. In the Presets section, select the Create new preset option. 

2. Enter the name of your new preset in the Name field. 
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Generating the layout 
Once you’ve defined your layout, there’s just one step left: 

1. Click OK. 

The layout is generated in HTML and opened in Expression Web. You can 
either save the page as a standard HTML page, a dynamic page or a 
template. If you chose to store your styles in an external style sheet, that 
style sheet is created, saved and opened as well. 

Note: Expression Web 1.0 has a problem rendering CSS properly when the 
content in a floated <div> tag, like sidebar, extends beyond the main 
content area. To see how the page would be properly displayed in the 
browser in Expression Web in this example, delete the last paragraph of 
placeholder content in the sidebar.  

 

Note: Once the page is generated, you cannot re-open it with CSS Sculptor; 
you can, however, create a new layout based on a saved preset. 
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Now you’re ready to begin replacing the placeholder content with your own 
and further customizing the CSS if desired. 

In the next section, you’ll learn how to manage your presets with the CSS 
Sculptor Layout Manager. 
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Managing Layouts 
CSS Sculptor’s ability to save new and modified presets presents a number of 
workflow opportunities for the Web professional. A designer may build up 
their own library of common layouts to be reproduced at will, complete with 
background images and preferred margins. To facilitate your efforts, CSS 
Sculptor includes the CSS Sculptor Layout Manager.  

Access the CSS Sculptor Layout Manger by choosing Insert > WebAssist > 
CSS Sculptor > Layout Manager. 

Once opened, the Layout Manager is populated with a list of all available 
preset layouts.  

 

There are six commands available in the Layout Manager: 

• New – Opens the CSS Sculptor interface. 

• Edit – Opens the CSS Sculptor interface with the selected layout pre-
loaded and available for modification. 

• Duplicate – Duplicates any selected layouts within the Layout 
Manager and makes them available for editing and other operations.  
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• Remove – Deletes any selected layouts from the Layout Manager. 

• Export – Exports an XML file with the information for the selected 
layouts. 

• Import – Imports an XML file exported from Layout Manager and 
makes the included layouts available for use with CSS Sculptor.  

To edit an existing layout: 

1. Open the CSS Sculptor Layout Manager using one of the methods 
described above. 

2. Select any listed layout. 

The Edit button is inactive unless a single layout is selected. 

3. Click Edit. 

CSS Sculptor opens with the chosen layout pre-selected and the 
Layout list is inactive. 

4. Make any modifications desired to the layout. 

5. In the Output tab Presets section, choose the desired preset option: 

• Don’t save a preset – Generates the layout without making any 
changes to the preset layout. 

• Overwrite existing preset – Modifies the selected layout to 
include the modifications. 

• Rename existing preset – Saves a new preset with the specified 
name. 

 

6. Click Finish. 

7. Choose another layout to edit or choose Done. 

To export layouts: 

8. In the CSS Sculptor Layout Manager, select one or more layouts. 
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You can make a multiple selection by pressing Ctrl (Windows) or Cmd 
(Mac) while clicking on entries or you can shift-select for contiguous 
entries. 

9. Click Export. 

 

10. In the Export Layouts dialog box, navigate to the desired folder and 
enter a name in the File name field for your exported layout file. 

11. When you return to the CSS Sculptor Layout Manager, click Done. 

To import layouts: 

1. In the CSS Sculptor Layout Manager, click Import. 
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2. When the Import Layouts dialog box appears, navigate to the desired 
folder and select the XML file previously exported from CSS Sculptor 
Layout Manager. Click Open. 

The imported layouts are listed alphabetically after the standard 
layouts. If an imported layout has the same name as an existing 
layout, the name is incremented; for example if you import a file with 
a layout called My New Layout and a layout with that name already 
exists, the new layout will be called My New Layout 2. 
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