
CSS Menu Writer Getting Started Guide 
With CSS Menu Writer you can easily creates Web-standards compliant CSS-
based menus – both horizontal and vertical, completely customized to your 
specifications.   

The Menu Writer wizard allows for easy reentry, making for easy 
modifications after you have initially created your menu. 

CSS Menu Writer is comprised of two key interfaces: one for creating new 
navigation menus and the other for managing preset menus.  

• Creating a Layout 

• Managing Layouts 

Each interface can be accessed in a couple of ways. You can begin to create 
new menus by any of these methods: 

• Choose Insert > WebAssist > CSS Menu Writer > New Menu. 

• Select the New CSS Menu Writer Menu option from the WebAssist 
category of the Insert bar. 

 

Likewise, the CSS Menu Writer Manager can be invoked by the following 
technique: 

• Choose Insert > WebAssist > CSS Menu Writer > Style Manager. 

• Select the New CSS Menu Writer Menu option from the WebAssist 
category of the Insert bar. 
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Creating a Navigation Menu 
CSS Menu Writer allows you to easily create CSS-based navigation menus.  
The Menu Writer wizard provides you with a wide range of options for 
customizing your navigation items. 

The CSS Menu Writer interface is divided into 4 tabs. 

 

• Menu – Determines the initial style and design of the navigation 
menu, specifies menu items and preset settings.  When specifying 
menu items you can choose to Get from file system to automatically 
import all website files in a directory. 

• Box – Sets the width and height of any menu component, as well as 
individual margin or padding values.  

• Type – Use the Type tab to determine a wide range of properties for 
the text of each menu item level.  This also covers text in the link, 
visited, hover, focus and active states. Properties available include 
font-family, font-size, color, decoration, and weight. 

• Design – The Design tab makes it possible to define the full set of 
background and border properties for any menu level.  This allows you 
to add a background image, left or right cap images, specify 
background color and image repeat settings. 

In the next section, you’ll begin to use CSS Menu Writer to create a 
navigation menu. 
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Choosing and modifying a preset style 
The first tab of CSS Menu Writer, Menu, establishes the basic appearance of 
the menu. CSS Menu Writer includes a collection of 8 different preset styles 
along with 11 designs, or color schemes to easily select an attractive menu.  
You can easily modify any of these preset styles to create your own, unique 
navigation menu.  

Note: Throughout this Getting Started Guide, I’ll choose a particular option 
or enter a set value. You’re free to experiment on your own and try different 
options; however, the screen shots in the Guide may not match your choices. 

To choose and modify a preset style: 

1. Open CSS Menu Writer by one of the following methods: 

• Choose Insert > WebAssist > CSS Menu Writer > New Menu. 

• Select the New CSS Menu Writer Menu option from the 
WebAssist category of the Insert bar. 

2. When CSS Menu Writer opens, choose a preset from the Style list. 
For this demonstration, I’ll choose Vertical Geo to create a vertical 
navigation menu. 

 

Once you choose a preset, the Preview window will update to show 
you the appearance of this menu, with the base color scheme. 

3. If you want to work with an overall color scheme, choose an entry 
from the Design list. I’ll select Pacifica. 

The 11 color schemes in CSS Menu Writer are also available in other 
WebAssist products like Eric Meyer’s CSS Sculptor, SiteAssist, 
DataAssist and SecurityAssist for a consistent look-and-feel. 
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Next, you will want to add which menu items you want included in your 
menu. 

You can configure your menu items by selecting Get from file system, 
or manually adding the menu items yourself.   

4. Select Item 1, and in the Name field enter Products. 

Note: After entering information in each field of the menu component 
window, hitting the Enter key ensures that each change is confirmed. 

5. In the link field, replace the # with products.html. 

In this example, we are going to create a multi-level side navigation that 
allows site visitors to easily navigation our product catalog. 

6. Next, select the Products item, and click once on the Add (+) 
button.  This will create a sub-menu item beneath products. 

7. In the Name field enter Gear. 

8. Enter gear.html in the link field. 

9. Select the Products item again and click the Add (+) button. 

10. In the name field for this item, enter Music. 

11. In the link field enter music.html. 

12. You can then select Item 2, and click the Delete button. 

13. Again, select Item 3, and click the Delete button. 
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14. To view your changes in the Preview window, click Apply. 

 

 

Saving Presets 

The Layout tab also provides the option to easily save a new preset that can 
be revisited at any time. 

To save a new preset 

1. In the Presets section, select the Create new preset option. 

2. Enter the name of your new preset in the Name field. 
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CSS Menu Writer is designed to be flexible and quick, allowing you to quickly 
create a functional navigation menu that contains all the features you would 
need.  You could, for example, click Finish here to create the navigation 
menu and accompanying CSS without making any additional changes. 
However, there is so much more possible with CSS Menu Writer; in the next 
section, you’ll modify the basic properties for the Box, Type, and Design tabs. 
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Adjusting the Box properties 
The Box tab provides the options for specifying the Dimensions, Margin and 
Padding for each menu item level. 

The Box tab introduces a user interface element common to a number of the 
other tabs in CSS Menu Writer, the menu level component window. The 
menu level component window shows each level of menu item, allowing you 
to select the level to apply changes to.  

 

• The menu level component window will display all menu levels.  The 
Main menu level is always the first level menu item, where Level 1 is 
the first sub-menu level.  

To modify the Box properties: 

1. From the menu level component window, choose Main. 

First, let’s add increase the height of the Main level item to be a little 
larger than its two sub-level items. 

2. In the Dimensions tab, enter 25 in the Height field, and hit the 
Enter key. 

3. Then, click Apply to see your changes. 

 

Notice that the Main Height column is updated in the menu level 
component control to read 25px.  
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Setting the Type 
CSS Menu Writer makes it easy for you to specify exactly what text you want 
used in each level of your navigation menu.  This sort of flexibility is valuable 
since it ensures that you can perfectly match the text with what is used 
throughout your site. 

To set the type properties: 

1. In the menu level component window, select the Main level. 

2. From the Link tab, choose Tahoma, Geneva, sans-serif from the 
Font list. 

3. In the Size field, enter 12.  Then, press Enter to confirm your choice. 
Click Apply to view your changes in the Preview window. 

 

Let’s also change the Level 1 menu items when the mouse is hovering 
over the item. 

4. From the menu level component window, select Level 1. 

5. Click the Hover tab and, from the Font list, choose Tahoma, 
Geneva, sans-serif.   

6. Set the Style to Bold. 

7. Click Apply to preview your changes in the Preview window. 

You also have the ability to preview your menu in a browser. 
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8. To see the new hover state in action, click once on your menu in the 
Preview window and test it out. 

 

This particular design calls for an underline decoration on the hover 
state (set on the body tag). You could easily change that here if you 
liked. 

In the next section, you’ll learn how to add background images and borders 
to any layout component. 
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Inserting Design elements 
Background images and borders are integral to modern CSS design. CSS 
Menu Writer makes it possible to add a background color or image, along 
with complete background properties to the body tag or any individual layout 
component. In addition, borders can be applied to surround menu items. 

To apply background images: 

Menu Writer makes it easy to incorporate any design you would like for your 
menu items.  Two of the preset design that Menu Writer comes packaged 
with, Horizontal Glow and Horizontal Bubble, use images to create a button 
effect.  You create this same effect using your own custom images. 

 

1. From the menu level component window, choose Main. 

2. In the Background & Border area, select the Link tab. 

3. Make sure the <a> sub tab is selected. 

Note:  Menu Writer uses three sub tabs for the different parts of a menu 
item.  The left cap <a>, the right cap <span> and the center <li>. 

4. Click the Filename browse icon. 

5. Select the left image that you wish to use. 

6. Select the Repeat value for this image. 

Note: Typically, the left and right cap images will not be repeated, and 
you would select no-repeat. 

7. Select the Horizontal and Vertical properties for this image. 

8. Repeat this process for the <span> and <li> sub tabs. 

Note:  For the <li>, or center image, you will most likely want to choose 
a repeat value in order for the image slice to repeat across the button. 
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The type of repeat necessary depends on the type of image you want to 
repeat.  Repeat-x will repeat an image horizontally, repeat-y will repeat 
an image vertically. 

9. When you are finished, choose Apply to update your preview. 

You will want to repeat this process for the other states of the image, 
Visited, Hover and Active. 

To apply a border: 

1. From the menu level component window, choose Main. 

2. In the Border area, make sure that the All checkbox is selected. 

3. From the Style list select solid and set the Width field to 1 pixel.  

4. From the color swatch field, select a dark gray color. 

5. Click the preview image to preview in your browser. 

Notice that you cannot see your border applied in the Preview window.  
This is because the preview window is displaying the Main menu level in 
its hover state. 

Let’s add the same border properties to the hover state. 

6. Select Hover tab, and in the Border area, make sure that the All 
checkbox is selected. 

7. Select solid from the Style menu, and set the Width field to 1 
pixel.  

8. From the color swatch field, select the same dark gray color. 

9. Click the preview image to preview in your browser. 
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Now that you have finished designing your menu item navigation, you are 
ready to have your menu inserted onto your page. 

10. Click Finish to create your menu. 
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Reentering the Menu Writer Wizard 
After using Menu Writer to create your menu, you may want to reenter the 
wizard to make additional changes.   

1. With your menu already inserted to your page, click once to select 
your menu. 

Note: HTML users will need to select the scripts icon next to the menu. 

When your menu is selected, the Dreamweaver Properties Inspector 
changes to provide an Edit button. 

2. Select Edit from the Property Inspector to reenter the Menu Writer 
wizard and make changes to your menu. 

 

HTML users: If the scripts icon is not displaying next to your menu, you 
will need to make a simple change to your Dreamweaver preferences. 

1. From the Edit menu, select Preferences. 

Mac users: Choose Dreamweaver, and select Preferences. 

2. From the Category list choose Invisible Elements. 

3. Make sure the Scripts option is selected. 

4. Click OK. 
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