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CSS Menu Writer v2 Getting Started Guide

With CSS Menu Writer 2.0 you can build horizontal or vertical CSS navigation
menus with ease. CSS Menu Writer comes pre-built with a variety of
categories and themes to choose from. These are provided to be starting
points for you to make the perfect CSS menu for your site.

This Getting Started Guide guides you through the process of creating a CSS
navigation menu with CSS Menu Writer.

What Do You Need to Start?

e Dreamweaver 8, CS3 or CS4
e (CSS Menu Writer 2.0

o Dreamweaver site defined

Using Dreamweaver Templates

To easily apply your navigation to all the pages in your site, it is advised that
you insert your menu within a Dreamweaver Template that is applied to all
the pages in your site. This way, any updates you make to your menu are
quickly applied to all pages when you save the changes made to your
template.

Quick Insert

CSS Menu Writer 2.0 has been designed to allow you to quickly insert a CSS
menu to your site, that you can then modify further at any time.

1. In Dreamweaver, open the page, or template you wish to contain your
menu.
If you intend to create dynamic menus, or are using a dynamic
document type, this page must be saved as this type.

2. Place your cursor in the region of your page or template where you
wish to have the menu inserted.
Typically the topnavigation div in CSS Sculptor designs.

3. From the Insert menu, choose WebAssist > CSS Menu Writer >
New Menu...
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4. From the Contents menu, choose a contents option that best matches
the type of site you are working with. Or, choose <New from blank> to
manually specify each menu item.

Why choose a Contents option? The Contents options are provided
to help speed up the menu development process. If you anticipate
having many items in your navigation, choosing the most applicable
option, and modifying the contents later, can save a lot of time.

5. From the Type menu, choose Horizontal or Vertical.

6. From the Category menu, choose the category that best suits your
needs.
If you have a particular menu design in mind, choose a category that
best matches your goal. You can then choose the Theme Define button
to further customize the design.

7. From the Theme menu, choose the theme (color scheme) that best
matches what you are looking for.
Click the Theme Define button to make further modifications.

8. Click OK to have the menu inserted to your page.
You can always reenter the Menu Writer wizard to make more
changes.

At this point, you probably have a functional navigation menu, but have
more changes to the contents and design that you would like to make.
The next sections cover how to customize the Contents and Design to
make your menu look as desired.

Reenter the wizard

You can reenter the CSS Menu Writer wizard easily after you have created
your menu.

1. Click once to select your navigation menu on your page.
HTML users will need to select the script icon & beside the menu.

PROPERTIES

% €SS Menu Writer | Editfenu | | Edit Contents | | Edit Theme |

2. Choose one of the following options depending on the changes you
wish to make:
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Edit Menu: Opens the primary CSS Menu Writer wizard.

Edit Contents: Opens the Edit Menu Structure interface for adding
and removing navigation items.

Edit Theme: Opens the 3-tab interface for customizing the look and
feel of your menu.

Refer to the other sections of this Getting Started Guide for assistance on
what you can accomplish in each of these sections.

Note: (HTML users) If you are not seeing the script icon beside your
menu, you need to turn on the ‘Scripts’ Invisible Elements option in
Dreamweaver.

e PC users: Choose Edit > Preferences, select the Invisible Elements
category.

e Mac users: Choose Dreamweaver > Preferences, select the
Invisible Elements category.
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Customizing the Contents

The Edit Menu Structure interface provides you with all the options for
adding, removing, renaming, and reordering any links you wish to include in
your menu.

By default, Menu Writer will provide you with three 1st level menu items,
with 3 sub-level items under Item 1. These are placeholders - feel free to
remove, or rename these items. If you chose an option from the Contents
menu in the primary interface, you will see all the links for those options. Use
this interface to make any modifications and assign the appropriate links to
any of the items included.

1. Access the Edit Menu Structure interface from one of the two following
options.
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Contents Define button
Available in the primary CSS Menu Writer interface

Menu: | <New Menu> -]
Contents: [quw from blank:= ']
Type: [Hnrimmﬁl v]
Catennry: [fhlnml from hlonl ']

Properties Inspector
After inserting your menu to your page, select the menu to view the

reentrant options in the Properties Inspector.
PROPERTIES

% £SS Henu Wiriter | Editfeny | | Edit Contents | | Edit Theme |
L

Adding new menu items

2. To add a new static menu item to your menu, choose the Add button,
then select Add new static link.

3. In the Label field, enter the text you wish to appear on the menu item.
€55 MENU WRITER™ - Static Menu ftem

The menu label will be displayed, and you wil be directed to the
URL of the page spedified.

Label: Support
Link: | fsuppart.php @

[] Do not show; enter menu item details on main dialog

WEBASSIST®  |sMblfons| [sntkon| [aance.

4. Choose the Link Browse icon, or enter the path to your menu item.
5. Click OK.

Your new menu item is inserted within the menu structure tree where you
can reorder the item, add additional child items, or delete any items.
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6. Once you have customized your menu structure as desired, click OK to
return to the primary CSS Menu Writer interface, or if accessed on
reentry, to have your changes applied to your existing menu.

Note: For assistance with Adding dynamic menu items refer to the
Creating dynamic menus with CSS Menu Writer How To.
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Customizing the Design

The CSS Menu Writer 3-tab interface allows you to completely customize the
design of your menu. This interface provides options for all levels of your
navigation menu, allowing you to easily customize each individual level to
appear exactly as desired.

What are the three tabs?

The following explains what type of modifications can be made in each of the
three tabs:

Box: Provides options for customizing the width, height, padding and
margin for the various elements of your menu.

Type: Provides options for specifying the font style, font size, font
color, etc. for the various text elements in your menu.

Design: Provides options for customizing the background colors,
background images and borders for your menu’s design.

Using the Menu Level Component Window

Each of the three tabs include the Menu Level Component Window which
displays the various levels of your navigation. You can add or delete levels,
and switch your menu from horizontal to vertical, at any time.

Note: If you delete a level, any menu items for that level will inherit the
properties for the level above it.

db Add il Delete Orientation:

Menu Level Group Margin Group Padding Width Height Margin Padding

Spx Spx Spx Spx
Level 1 100px oooo Spx S5px Spx Spx
Level 2 100px oooo Spx Spx Spx Spx
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Modifying the Box properties

Use the Box tab to make any modifications to your menu’s width and height
or margins and padding.

C55 MEMU WRITER™ - Edit Menu Theme

Calart amur marmi lavwal tamictamira tho marnin and naddina rranartice Dranartice ara inharited fram ano mamn lowal fn Hha na
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From the Menu Level Component Window, select the level of your
menu you wish to customize.

Choose the Group or Item tab.

Group: Modifications are applied to all items within the selected level.
Item: Changes are applied to the individual items within the selected
level.

. Specify any settings you like.

For example, to modify the width of the menu items, follow these
steps:

1. Choose the Item tab.
2. Enter the desired width in the Width text field.
3. Specify the units from the Width menu list.

Click the Apply button to view your modification in the Preview
window.

Click on the menu in the preview window to view the menu in your
browser.

Select the next menu level you wish to modify from the Menu Level
Component window.

Make any changes to the settings.
Click Apply to preview your changes.
Continue making any changes to the Box properties.

When finished, proceed to the next tab, or click Finish.
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Modifying the Type properties

Use the Type tab to make any modifications to your menu’s text properties.
€55 MENLU WRITER™ - Edit Menu Theme
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1. From the Menu Level Component Window, select the level of your
menu you wish to customize.

2. Choose whether you wish to customize the Link, Visited, Hover, or
Active state of your menu’s text.

Note: The Link state is the primary state for your menu, if there are no
styles defined for the other 3 tabs, the text will display according to the
Link state styles.

3. Specify the settings you would like for your text.

4. Click the Apply button to view your modification in the Preview
window.

5. Continue to make changes to the other states until you have the text
properties you desire.

6. From the Menu Level Component Window, select the next menu level
you wish to customize.

7. Make any modifications to the type properties for the various states.

8. Once you have made all your desired changes, proceed to the next
tab, or click Finish.
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Modifying the Design elements

Use the Design tab to make any modifications to your menu’s appearance,
including background colors, images, and borders.

C55 MEMNU WRITER™ - Edit Menu Theme

m
Select anv menu level to customize the backaround and border oroperties, Properties are inherited from one menu level to the nex

1. From the Menu Level Component Window, select the level of your
menu you wish to customize.

2. Choose whether you wish to customize the Link, Visited, Hover, or
Active state of your menu’s design.

3. Choose the appropriate Background tab depending on the change you
wish to make:

<span>: Allows you to specify a right cap image to create a rounded
edge appearance to your menu item.

<a>: Allows you to specify a left cap image to create a rounded edge
appearance to your menu item.

<li>: Sets the background properties for the menu item.
Make any desired change to the background of your menu.
Specify a border, if desired.

Click Apply to view your changes in the preview window.

N o oo

. Choose any other menu levels or a different link state to make further
customizations.

8. Once you have made all your desired changes, click Finish.
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Saving presets

CSS Menu Writer will provide you the option to save a preset after you click
Finish in most interfaces. This option is presented to you after creating new
menu contents, and modifying a menu theme (design).

It is recommended that you save a new preset each time, allowing you to
reuse your custom menu designs and contents for other websites. Also, this
allows you to maintain a backup by exporting this layout from the WebAssist
Preset Manager.

1. Select the Save as preset checkbox.

2. Choose a Category, or enter a new category name.
3. Choose a Theme, or enter a new theme name.
4

Click OK.
€55 MENU WRITER™ - Save Menu Theme ==

To save changes to an existing theme preset, choose the Save as
preset option and enter a new name to create a new preset
category andfor theme. If you don't want to save your changes as
a preset, dear the chedkbox and didk OK,

Save as preset

Category: -
Theme: EEemH -

WEBASSIST®  |shitbe| [tk feancit.|
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